[P4-dev] switch/bmv2/run_of_tests.sh not running properly

Bob Miller misterbobmiller at gmail.com
Mon Jul 10 14:59:11 EDT 2017


Hi,
    I am just getting started with the P4 language and am running into a
problem with running the OpenFlow Tests contained in the switch
repository.  I followed the instructions in the switch repository README
for "Running switch in bmv2 without p4factory", compiling and installing
the other repositories as suggested.

Running the run_tests.sh passed as follows:

In terminal window 1 I started the software switch with:

     sudo ./bmv2/run_bm.sh

In terminal window 2, I started the drivers with:

     sudo ./bmv2/run_drivers.sh

Then I ran the tests in a third terminal window:

     sudo ./bmv2/run_tests.sh

The run_tests.sh ran with no errors and passed all the tests.  However when
I ran the OpenFlow tests, after installing p4ofagent, as follows:

     sudo ./bmv2/run_of_tests.sh

     The drivers running in terminal window 2 faulted with the following:

07-07 17:19:54.871555 [ofconnectionmanager] Connected to controller
0.0.0.0:6653
In client_init
In bd_action_profile_add_member_with_set_bd_properties
In port_vlan_mapping_add_entry
In bd_action_profile_add_member_with_set_bd_properties
In port_vlan_mapping_add_entry
In mc_mgrp_create
In mc_node_create
In mc_associate_node
terminate called after throwing an instance of
'apache::thrift::TApplicationException'
   what():  _Map_base::at
./bmv2/run_drivers.sh: line 11: 52829 Aborted $DRIVERS_EXE $@


Any help with what I might be running incorrectly would be greatly
appreciated. Also if there is a better approach than the "switch without
p4factory" for getting started with P4 and OpenFlow let me know.

Thanks,
Bob Miller
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.p4.org/pipermail/p4-dev_lists.p4.org/attachments/20170710/98abe02d/attachment-0002.html>


More information about the P4-dev mailing list