[P4-dev] Issues running P4D2_2017 exercises

Antonin Bas antonin at barefootnetworks.com
Tue Jun 6 20:02:11 EDT 2017


Duplicate of a github issue: https://github.com/p4lang/tutorials/issues/38

On Tue, Jun 6, 2017 at 11:44 AM, Yu, James (Nokia - US/Sunnyvale) <
james.yu at nokia.com> wrote:

> Hi,
>
> My VM was copied from USB during P4 Developer Day 2017, so it should be
> good.
> I can’t get the reference solution of ipv4_forward to run correctly.
> After examining
> the logs, the LPM lookup resulted in a miss (used the correct
> ipv4.dstAddr). The table
> for S1 was populated during runtime, according to the messages. However,
> for all the
> switches, there were errors similar to:
>
> No handlers could be found for logger "thrift.transport.TSocket"
> Could not connect to thrift client on port 909x (x = 0, 1, 2)
>
> right after all the table_adds.  This looks a bit suspicious and could
> explain for the
> behavior I’m seeing.  I’m always executing “mn -c” and the rest of
> commands to clear
> mininet, but that doesn’t make any difference.
>
> I also couldn’t run another reference exercise, but didn’t pursue it
> further.  BTW, I’m
> running VirtualBox on Windows.  I appreciate any pointers people might
> have.  Thanks
> so much.
>
> James
>
>
>
> _______________________________________________
> P4-dev mailing list
> P4-dev at lists.p4.org
> http://lists.p4.org/mailman/listinfo/p4-dev_lists.p4.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.p4.org/pipermail/p4-dev_lists.p4.org/attachments/20170606/7f9ae5c7/attachment-0002.html>


More information about the P4-dev mailing list