[P4-dev] Bug within Mininet Example 1sw_demo

He, Mu mu.he at tum.de
Tue Jan 30 06:41:11 EST 2018


Hi,

When I tried the Mininet integration code example 1sw_demo.py, everything went smoothly, except closing the Mininet CLI.
After I typed in "exit" in the CLI, I got the following error messages.
Traceback (most recent call last):
  File "1sw_demo.py", line 114, in <module>
    main()
  File "1sw_demo.py", line 110, in main
    net.stop()
  File "build/bdist.linux-x86_64/egg/mininet/net.py", line 574, in stop
  File "build/bdist.linux-x86_64/egg/mininet/link.py", line 506, in stop
  File "build/bdist.linux-x86_64/egg/mininet/link.py", line 499, in delete
  File "build/bdist.linux-x86_64/egg/mininet/link.py", line 205, in delete
  File "build/bdist.linux-x86_64/egg/mininet/node.py", line 441, in delIntf
KeyError: 'eth0'

I try to track down the error, and it looks like the interface of P4Host is the one with name "eth0". However, I am not able to fix this bug.
Does anyone experience the same error? How do you fix it?

Best regards,

_________________________________________________
Mu He
Chair of Communication Networks
Technische Universität München
Arcisstr. 21, 80333 München
Phone: +49 89 289 23505

Mailto: mu.he at tum.de<mailto:mu.he at tum.de>
Web: www.lkn.ei.tum.de<http://www.lkn.ei.tum.de/>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.p4.org/pipermail/p4-dev_lists.p4.org/attachments/20180130/4a6b8a01/attachment-0002.html>


More information about the P4-dev mailing list