[P4-dev] Missing json files when compiling several .p4 files

Ruiyang Chen rc5 at illinois.edu
Sun Feb 3 18:43:24 EST 2019


Hi Andy,
Thanks for the quick reply! The Make file i'm using is the Makefile in p4
tutorials.
https://github.com/p4lang/tutorials/blob/master/exercises/basic/Makefile
(The makefile in the basic tutorial)
https://github.com/p4lang/tutorials/blob/master/utils/Makefile (the
makefile included in the first Makefile)

Best,
Ruiyang

On Sun, Feb 3, 2019 at 3:17 PM Andy Fingerhut <andy.fingerhut at gmail.com>
wrote:

> It may be easier to help you if you give a link to some Makefile in some
> existing public repository that you have cloned and then modified, and
> perhaps also a description of any changes you have made so far, e.g. a copy
> of your Makefile, if you have changed your copy.
>
> Andy
>
>
> On Sun, Feb 3, 2019 at 12:00 PM Ruiyang Chen <rc5 at illinois.edu> wrote:
>
>> Hi everyone,
>> I'm new to p4 and faced some problem. I was trying to have 3 different p4
>> file for 3 different switches in the network, and the Makefile will give me
>> error that "cannot find json file for target build".(It'll create a json
>> file for the first p4 file but not for the other 2.) I have looked at the
>> Makefile and wasn't sure which step is to create the json file in "build"
>> directory corresponding to the p4 files in the current directory.  Any help
>> on how to modify the makefile to compile several .p4 codes will be
>> appreciated! Thanks!
>>
>> Best,
>> Ruiyang Chen
>> _______________________________________________
>> P4-dev mailing list
>> P4-dev at lists.p4.org
>> http://lists.p4.org/mailman/listinfo/p4-dev_lists.p4.org
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.p4.org/pipermail/p4-dev_lists.p4.org/attachments/20190203/8061bbc8/attachment.html>


More information about the P4-dev mailing list