<div dir="ltr">Hi there,<div><br></div><div>Sorry for the late reply. This was caused by a bug in p4factory which is now fixed.</div><div><br></div><div>Thanks,</div><div><br></div><div>Pierce</div></div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Sep 20, 2016 at 12:36 AM, Sandaruwan Jayaweera <span dir="ltr"><<a href="mailto:sandaruwangayantha@gmail.com" target="_blank">sandaruwangayantha@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">


        
        
        
        


<p style="margin-bottom:0.2in;line-height:100%">Hi all,</p>
<p style="margin-bottom:0in;line-height:100%">I'm trying to
connect the switch target in the p4factory with the ryu openflow
controller. 
</p><br>I generated the
behavioral-model in p4factory/targets/switch using<i><b><br></b></i><p style="margin-bottom:0in;line-height:100%"><i><b>make
bm-p4ofagent PLUGIN_OPENFLOW=1</b></i><br></p><br>I started ryu app
using <i><b>ryu-manager ryu/app/simple_switch_13.py</b></i><span style="font-style:normal"><span style="font-weight:normal"></span></span><br><p style="margin-bottom:0in;font-weight:normal;line-height:100%"><span style="font-style:normal"><span style="font-weight:normal"></span></span></p><span style="font-style:normal"><span style="font-weight:normal">But
when I execute </span></span><i><b>sudo python </b></i><i><b>openflow_l2.py
–</b></i><i><b>controller-ip 127.0.0.1</b></i><span style="font-style:normal">
the 2 hosts are unable to ping.</span><span style="font-style:normal"></span><br><p style="margin-bottom:0in;line-height:100%"><span style="font-style:normal"></span></p><span style="font-style:normal">I
checked the packet-dumps and the controller is receiving packet-ins
and sending the packet-outs </span><span style="font-style:normal">to
the ARP packets</span><span style="font-style:normal"> when I use </span><i>h1
ping h2</i><span style="font-style:normal">. </span><span style="font-style:normal">But
the switch is not doing any further action. Can anyone give any hints? What should be the flow when
running an openflow</span><span style="font-style:normal"> enabled
target?</span><span class="HOEnZb"><font color="#888888"><span style="font-style:normal"><br><br>Sandaruwan<br><br></span> <span style="font-style:normal"></span></font></span></div>
<br>______________________________<wbr>_________________<br>
P4-dev mailing list<br>
<a href="mailto:P4-dev@lists.p4.org">P4-dev@lists.p4.org</a><br>
<a href="http://lists.p4.org/mailman/listinfo/p4-dev_lists.p4.org" rel="noreferrer" target="_blank">http://lists.p4.org/mailman/<wbr>listinfo/p4-dev_lists.p4.org</a><br></blockquote></div><br></div>