<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
</head>
<body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space; color: rgb(0, 0, 0); font-size: 14px; font-family: Calibri, sans-serif;">
<div>Hi,</div>
<div><br>
</div>
<div>I  am building a p4runtime for a new target, so was looking at the grpc_demo app in the PI repository. It looks like the latest PI requires protobuf 3.4 (otherwise there is a known compile error in grpc). However, p4c-16 itself, in the README.md, says
 to stick with 3.0.x.</div>
<div><br>
</div>
<div>Does anyone know if p4c has any known problems with protobuf 3.4.x, as it is a pain to have two different versions of protoc in our dev environment.</div>
<div><br>
</div>
<div>Thanks,</div>
<div>Alan </div>
</body>
</html>